$self->create_user( username => $username, email => $email, pass_token => $pass_token );I wish I could get rid of the naming redundancy in this call:
$self->create_user( $username, $email, $pass_token );(without changing 'create_user' of course).
Probably some new syntax would be needed.