Tuesday, May 27, 2008

Installing Test::WWW::Mechanize::Catalyst

It seems that there is some incompatibility between the latest LWP version (5.812) and Test::WWW::Mechanize::Catalyst. The tests die with an:

HTTP::Message content must be bytes at lib/Test/WWW/Mechanize/Catalyst.pm line 88

error message. After downgrading LWP to 5.808 Test::WWW::Mechanize::Catalyst (version 41 - which looks better than 42 at CPAN Testers: Reports for Test-WWW-Mechanize-Catalyst) worked. Looks like this change is the culprit: "Don't allow HTTP::Message content to be set to Unicode strings".

confound - thanks for the hint.


Jimpa Stimpa said...

I just installed the following and everything was a ok

sudo cpan Test::WWW::Mechanize::Catalyst

zby said...

Well - I wrote that two years ago - I guess it has changed since then.